import re
regex = re.compile(r"^(Em\s\w+,\s)|(Em\s)?\d{1,2}\sde\s\w+\sde\s\d{4}\s(às\s)?\d{1,2}:\d{1,2}([^@]+@\w+\.\w+\.\w+|,\s\sescreveu\:)?", flags=re.MULTILINE)
test_str = ("teste\n\n\n"
"Em qua, 11 de abr de 2018 às 09:08, wmsouza <teste@hotmail.com> escreveu:\n\n"
"Em 11 de abr de 2018\n\n"
" Não sei\n"
" Assunto:\n\n\n"
"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.\n\n"
"5 de Abril de 2018 10:50, atendimento@teste.com.br (mailto:atendimento@teste.com.br) escreveu:teste\n\n"
"Em 5 de Abril de 2018 10:30, atendimento@teste.com.br (mailto:atendimento@teste.com.br) escreveu:resposta atendimento\n\n"
"-----------------------------------------------------------\n\n"
"Olá, como vai?\n\n"
"10 de abril de 2018 09:49\n\n"
"10 de abril de 2018 09:49, escreveu:\n\n"
"Em 10 de abril de 2018 09:49\n\n"
"Em 10 de abril de 2018 09:49, escreveu:\n\n"
"> Resposta atendimento\n"
">\n"
">\n"
"> 10 de Abril de 2018 09:48, \"erick zanetti\" > escreveu:\n"
">\n"
">\n"
"> Olá, erick,\n"
"> A data de entrega do seu trabalho Lista Vetores\n"
"> é\n"
"> amanhã. Você deseja entregá-lo?\n"
">\n"
">\n"
"> Lista Vetores\n"
"> Prazo: 7 de abr\n"
"> ABRIR\n"
">\n"
"> Se você não quiser receber e-mails do Sala de aula, cancele sua inscrição\n"
"> .\n"
">\n"
">\n"
">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")