re = /(?<![_\p{L}])CAR_COMPONENTS(?![_\p{L}])/m
str = 'CAR_COMPONENTS_ADT CAR_COMPONENTS_ADT1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end