import re
regex = re.compile(r"\d\d\:\d\d", flags=re.MULTILINE)
test_str = ("=! VANHOLLANO DUMAI!\n\n"
" !12/5/2018 ! !07:26!\n"
"!Jl. Jend. Sudirman No. 183 Dumai \n"
"Hp. 08116252883 \n"
"IDN !\n"
"! !\n"
"!vbdumsdr01 ! !Novita !\n"
"!Cust. Name..: ! ! !\n"
"! !\n"
"!---------------------------------!\n"
"! 1! !SHOPPING BAG SMALL! ! 0!\n"
"! 2! !PALMIER ! ! 7,400!\n"
"! 1! !ROTI SISIR KELAPA ! ! 15,800!\n"
"! ! ! !\n"
"!---------------------------------!\n"
"!Subtotal ! ! 23,200!\n"
"!Total Discount ! ! 0!\n"
"!PB1 ! ! 2,320!\n"
"!Total ! ! 25,520!\n\n"
"!Cash ! ! 50,500!\n\n"
"!Change back (Cash) ! ! 24,980!\n"
"!=================================!\n\n"
" ! PERIKSA KEMBALI!\n"
"!struk belanja dan uang kembalian !\n"
" !anda. Komplain hanya bisa!\n"
"!dilakukan saat transaksi di kasir!\n\n"
" !Customer Service!\n"
" !SMS: 08117541984!\n"
" !PIN BB: 2B4DCF32!\n\n"
" ! FOLLOW US!\n"
"!ig : vanhollanobakery_jnpgroup !\n"
" !www.jnp-g.com!\n"
" !Thank You!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")