$re = '/\b(a)?b(?(1)c|d)\b/m';
$str = 'abc
bd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);