import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"class[0-9]+\\\"+";
final String string = "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"AHA\" : \"class65\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Liv…eed\" : \"class66\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Tab…ion\" : \"class67\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Mon…ing\" : \"class68\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Usa…ics\" : \"class69\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Ser…ing\" : \"class70\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Rep…ing\" : \"class71\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Ben…rks\" : \"class72\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Ser…tal\" : \"class73\"\n"
+ "INFO | jvm 2 | 2022/11/02 14:53:11.612 | \"Dep…ap)\" : \"class74\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}