$re = '/^([0]?[1-9]|[1-2]\d|3[0-1])-(JAN|FEB|MAR|APR|MAY|JUN|JULY|AUG|SEP|OCT|NOV|DEC)-[1-2]\d{3}$/m';
$str = '7-JUN-2008
07-JUN-2008';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);