package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}$`)
var str = `111.111.111.111
251.5.5.7
00
01
05
20
25
248.255.0.5
127.0.1.0
132
127012
10.10.10.10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}