re = /<comment:(\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/)>/i
str = '<comment:/* *What is that?
* I do not know!
*/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end