$re = '/xnum-(\S+)/';
$str = 'xnum-539 classname random-word xnum-hello hi-239';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);