# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[0-9]+\b(?! [A-Z])/XXXX/gm;t' <<< "Error trying to POST to /shipments/28056415973/select?caller.id=116089592: 500 INTERNAL_SERVER_ERROR
"