$re = '/^(?!(?:.*\d+){3,})[a-z0-9]{3,}$/m';
$str = 'abc
abc12
abc123
a12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);