using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lookaround(?:(?!(?:match|lookaround)).)*match";
string input = @"Lookahead and lookbehind, collectively called ""lookaround"", are zero-length assertions just like the start and end of line, and start and end of word anchors explained earlier in this tutorial. The difference is that lookaround actually matches characters, but then gives up the match, returning only the result: match or no match. That is why they are called ""assertions"". They do not consume characters in the string, but only assert whether a match is possible or not. Lookaround allows you to create regular expressions that are impossible to create without them, or that would get very longwinded without them.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}