$re = '/^[^-]*-/m';
$str = 'ip-255-25-255-255';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);