#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\h*[^-\s].*)\R(?!-)"
Local $sString = "- test 1" & @CRLF & _
" test test test" & @CRLF & _
" test test test" & @CRLF & _
" test test test" & @CRLF & _
"- test2" & @CRLF & _
"- test3" & @CRLF & _
" test test t" & @CRLF & _
" test test test" & @CRLF & _
"- test 4" & @CRLF & _
" test test test" & @CRLF & _
"- test5" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)