$re = '/[A-Za-z]+\b(?!:)/m';
$str = 'real:c
Help:lala
lame:joker';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);