$re = '/^[a-z]{2}-[A-Z]{2}$/m';
$str = 'tr-TR
us-US';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);