$re = '/\'(\w+)\'\s*:/m';
$str = '{\'id\': 613, \'name\': "new year\'s eve"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);