$re = '/.*(?<!\.d)\.ts/m';
$str = 'src/code-frame.d.ts
src/foo.ts
src/index.ts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);