package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Server Version: )+(\d*\.?\d+\.\d)`)
var str = `Client Version: openshift-clients-4.3.0-201910250623-88-g6a937dfe Server Version: 4.3.0 Kubernetes Version: v1.16.2:q`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}