import re
regex = re.compile(r"On-Demand Color:\s(\S+)(?:\n(?!On-Demand Color:|\s*Liveness-detection:).*)*\n\s*Liveness-detection: Enabled", flags=re.MULTILINE)
test_str = ("RA#show segment-routing traffic-eng on-demand color detail | utility egrep Color -B 10\n"
"Sat Dec 25 11:24:22.891 JST\n\n"
"SR-TE On-Demand-Color database\n"
"------------------------\n\n"
"On-Demand Color: 20\n"
"--\n"
" Performance-measurement:\n"
" Reverse-path Label: Not Configured\n"
" Delay-measurement: Disabled\n"
" Liveness-detection: Enabled 《-------\n"
" Profile: liveness1\n"
" Invalidation Action: down\n"
" Logging:\n"
" Session State Change: Yes\n"
" Per-flow Information:\n"
" Default Forward Class: 0\n"
"On-Demand Color: 23\n"
"--\n\n\n\n\n\n\n"
" Performance-measurement:\n"
" Reverse-path Label: Not Configured\n"
" Delay-measurement: Disabled\n"
" Liveness-detection: Enabled 《--------\n"
" Profile: liveness1\n"
" Invalidation Action: down\n"
" Logging:\n"
" Session State Change: Yes\n"
" Per-flow Information:\n"
" Default Forward Class: 0\n"
"On-Demand Color: 301")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")