re = /^(nfs:\/\/)(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?):([0-9]{4})/m
str = 'nfs://172.1.1:2049
nfs://172.1.1.5:2049
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end