const regex = /(?<href>(?<origin>(?<protocol>(?<scheme>[a-z][\w\-]{2,}):)?(?:\/\/+)?)?(?:(?<username>[^:\s]*)(?::(?<password>[^@\s]*))?@)?(?<host>\B\.{1,2}\B(?=[a-z\d]|\/)|(?<=[\\\/])[A-Z]:|(?<hostname>(?:[a-z][a-z-]*)(?:\.[a-z][a-z-\.]*|(?=\/))|(?:[^\s\$]\d[a-z\d-]*)(?:\.[a-z][a-z-\.]*)|(?:(?:25[0-5]|(?:2[0-4]|1\d|[1-9])?\d)(?:\.(?!$)|\b)){4}|localhost)(?:\:(?<port>\d+))?)(?<pathname>\/[^?#\s]*)?(?<search>\?[^#\s]*)?(?<hash>#[^\s]*)?)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<href>(?<origin>(?<protocol>(?<scheme>[a-z][\\w\\-]{2,}):)?(?:\\\/\\\/+)?)?(?:(?<username>[^:\\s]*)(?::(?<password>[^@\\s]*))?@)?(?<host>\\B\\.{1,2}\\B(?=[a-z\\d]|\\\/)|(?<=[\\\\\\\/])[A-Z]:|(?<hostname>(?:[a-z][a-z-]*)(?:\\.[a-z][a-z-\\.]*|(?=\\\/))|(?:[^\\s\\$]\\d[a-z\\d-]*)(?:\\.[a-z][a-z-\\.]*)|(?:(?:25[0-5]|(?:2[0-4]|1\\d|[1-9])?\\d)(?:\\.(?!$)|\\b)){4}|localhost)(?:\\:(?<port>\\d+))?)(?<pathname>\\\/[^?#\\s]*)?(?<search>\\?[^#\\s]*)?(?<hash>#[^\\s]*)?)', 'i')
const str = `https://user:pass@api.twitch.tv:8080/Kshipa?popout=true#unload`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}