import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-z\\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\\-]+( )+?=( )+?(:id)";
final String string = " id = :id\n"
+ " id = id\n\n"
+ "SELECT * FROM A ID IN (select ID from users where id_ec = :id)\n\n"
+ "select * from users where id = :id and name = :name\n\n"
+ "select * from users where name = :name and id = :id aNd name = :name\n\n\n"
+ "select * from users where name = :name and name = :name and id = :id";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}