re = /^(?!.*html.*).*\.php$/m
str = 'foo.html.htm.php
foo.bar
foo.php
foo.bar.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end