$re = '/.*(?<!\.html)\.php$/m';
$str = 'foo.html.php
foo.bar
foo.php
foo.bar.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);