re = /(?!<xref[^>]*>)(-)(?![^<]*<\/xref>)/
str = 'asdf-asdf<xref ref-type="fn-1"/>
asdf-asdf<xref ref-type="fn-1"></xref>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end