re = /([-\[\]{}()*+?.,\\\/^$|#])/
str = 'RewriteRule . - [E=REWRITEBASE:/]'
subst = '\\\\$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result