#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(?#remove next set of parenthesis and content because its only for simulating automod)(^|\W|\b)(?<!player\.)(?<!blog\.)(?<!dev\.)(?<!link\.)(?<!affiliate\.)(?<!meetups\.)(?<!help\.)(?<!safety\.)(?<!devstatus\.)(?<!brand\.)(?<!sings\.)(?<!music\.)twitch\.tv\/(?!embed(\/|\b)|subs(\/|\b)|directory(\/|\b)|p\/|user(\/|\b)|legal(\/|\b)|admin(\/|\b)|login(\/|\b)|signup(\/|\b)|jobs(\/|\b)|videos(\/|\b)|collections(\/|\b)|downloads(\/|\b)|turbo(\/|\b)|store(\/|\b)|creatorcamp(\/|\b)|settings(\/|\b)|giftcard(\/|\b)|redeem(\/|\b)|broadcast(\/|\b)|partner(\/|\b)|bits(\/|\b)|prime(\/|\b))(\w+)\/?(?!\S)(?#remove next set of parenthesis and content because its only for simulating automod)($|\W|\b)"
Local $sString = "https://www.twitch.tv/miametzmusic" & @CRLF & _
"https://www.twitch.tv/miametzmusic" & @CRLF & _
"https://twitch.tv/summit1g" & @CRLF & _
"https://twitch.tv/summit1g/" & @CRLF & _
"https://www.twitch.tv/subsp00ky" & @CRLF & _
"https://www.twitch.tv/subsp00ky/" & @CRLF & _
"" & @CRLF & _
"https://player.twitch.tv/js/embed/v1.js" & @CRLF & _
"https://player.twitch.tv/?channel=miametzmusic&parent=www.example.com" & @CRLF & _
"https://www.twitch.tv/embed/miametzmusic/chat?parent=www.example.com" & @CRLF & _
"https://www.twitch.tv/subs" & @CRLF & _
"https://www.twitch.tv/subs/miametzmusic" & @CRLF & _
"https://www.twitch.tv/directory" & @CRLF & _
"https://www.twitch.tv/directory/all/tags/classical" & @CRLF & _
"https://www.twitch.tv/miametzmusic/about" & @CRLF & _
"https://www.twitch.tv/miametzmusic/schedule" & @CRLF & _
"https://www.twitch.tv/miametzmusic/videos" & @CRLF & _
"https://www.twitch.tv/videos/1821013434" & @CRLF & _
"https://www.twitch.tv/videos/1821013434?t=00h00m13s" & @CRLF & _
"https://www.twitch.tv/collections/EwAtC1IWzhY3Ww" & @CRLF & _
"https://www.twitch.tv/videos/1277407565?collection=EwAtC1IWzhY3Ww" & @CRLF & _
"https://www.twitch.tv/videos/1277407565?collection=EwAtC1IWzhY3Ww&t=00h00m52s" & @CRLF & _
"https://player.twitch.tv/?collection=EwAtC1IWzhY3Ww&video=1277407565&parent=www.example.com" & @CRLF & _
"https://player.twitch.tv/?collection=EwAtC1IWzhY3Ww&video=1277407565&time=0h2m27s&parent=www.example.com" & @CRLF & _
"" & @CRLF & _
"https://www.twitch.tv/p/giftcard/" & @CRLF & _
"https://www.twitch.tv/p/about" & @CRLF & _
"https://www.twitch.tv/p/en/about/" & @CRLF & _
"https://blog.twitch.tv/" & @CRLF & _
"https://blog.twitch.tv/en/" & @CRLF & _
"https://blog.twitch.tv/en/archive/2023/" & @CRLF & _
"https://dev.twitch.tv/" & @CRLF & _
"https://dev.twitch.tv/products/" & @CRLF & _
"https://www.twitch.tv/downloads" & @CRLF & _
"https://www.twitch.tv/jobs" & @CRLF & _
"https://www.twitch.tv/jobs/en/" & @CRLF & _
"https://www.twitch.tv/turbo" & @CRLF & _
"https://www.twitch.tv/store" & @CRLF & _
"https://www.twitch.tv/creatorcamp" & @CRLF & _
"https://www.twitch.tv/creatorcamp/en/paths/" & @CRLF & _
"https://www.twitch.tv/settings/security" & @CRLF & _
"https://link.twitch.tv/devchat" & @CRLF & _
"https://affiliate.twitch.tv/" & @CRLF & _
"https://meetups.twitch.tv/" & @CRLF & _
"https://meetups.twitch.tv/events" & @CRLF & _
"https://help.twitch.tv/" & @CRLF & _
"https://help.twitch.tv/s/article/getting-started-twitch-studio" & @CRLF & _
"https://www.twitch.tv/giftcard/buy?ref_=gc_twitch_landing" & @CRLF & _
"https://www.twitch.tv/redeem" & @CRLF & _
"https://safety.twitch.tv/" & @CRLF & _
"https://safety.twitch.tv/s/article/Usernames" & @CRLF & _
"https://devstatus.twitch.tv/" & @CRLF & _
"https://devstatus.twitch.tv/uptime" & @CRLF & _
"https://www.twitch.tv/broadcast/studio" & @CRLF & _
"https://brand.twitch.tv/" & @CRLF & _
"https://brand.twitch.tv/downloads/twitch-brand-assets.zip" & @CRLF & _
"https://www.twitch.tv/partner/signup" & @CRLF & _
"https://www.twitch.tv/bits" & @CRLF & _
"https://www.twitch.tv/prime" & @CRLF & _
"https://sings.twitch.tv/" & @CRLF & _
"https://music.twitch.tv/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")