const regex = /(.*?)<div.*div>(.*)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)<div.*div>(.*)', 'gs')
const str = `"<img width="300" src="https://www.dvrgv.org/PhotosArticles/2017-07-25-VeloTaxi.jpg" alt="Manu dans le vélo-taxi, Brigitte aux commandes" /><br />
<P>En juillet 2017, </P>
<div class="powerpress_player" id="powerpress_player_9779"><!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->
<audio class="wp-audio-shortcode" id="audio-1097-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://www.dvrgv.org/_Reportages/2017-07-26-BrigiteVeloTaxi.mp3?_=1" /><a href="https://www.dvrgv.org/_Reportages/2017-07-26-BrigiteVeloTaxi.mp3">https://www.dvrgv.org/_Reportages/2017-07-26-BrigiteVeloTaxi.mp3</a></audio></div>dddf"
`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);