$re = '/https?:\/\/.\S+(?=<)|(?<=> > )\S+(?=<)/m';
$str = 'https://google.com<span class="dyjrff qzEou role="Text"> > dalesch-6eved497<span class="dyjrff qzEou role="Text">>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);