re = /^ *([+-](?!.*[-+]))?\d*\.?\d*[+-]? *$/m
str = '-1.23
-1.23
-1.23
1.23-
-1.23- '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end