#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "modified:\s+((?>\w+\/?)+)[^)\v]*\)"
Local $sString = " modified: apps/aaaaaa/bbbbbb/ccccff" & @CRLF & _
" modified: apps/ami (new commits)" & @CRLF & _
" modified: apps/assess (new commits)" & @CRLF & _
" modified: apps/ees121 (new commits)" & @CRLF & _
" modified: apps/energy_bourse (new commits)" & @CRLF & _
" modified: apps/gis (new commits)" & @CRLF & _
" modified: apps/hse (new commits)" & @CRLF & _
" modified: apps/aa/aaa/a/bb/b/bb/bc/c22/s/df/s/" & @CRLF & _
" modified: apps/management (new commits)" & @CRLF & _
" modified: apps/payesh (new commits)" & @CRLF & _
" modified: external_apps (modified content)" & @CRLF & _
" modified: modules/esb_server (new commits)" & @CRLF & _
" modified: modules/formbuilder (new commits, modified content)" & @CRLF & _
" modified: modules/reporting (new commits)" & @CRLF & _
" modified: modules/safir (new commits)" & @CRLF & _
" modified: modules/workflow (new commits)" & @CRLF & _
" modified: vendor/raya_framework/client (new commits)" & @CRLF & _
" modified: vendor/raya_framework/core (new commits)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")