// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\w{4,}\b").unwrap();
let string = "hello, bonjour bonjour, ceci est un test dans lequel bonjour est écrit cinq fois et test seulement quatre fois, bonjour test, bonjour test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}