package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w{4,}\b\b\w{4,}\b`)
var str = `hello, bonjour bonjour, ceci est un test dans lequel bonjour est écrit cinq fois et test seulement quatre fois, bonjour test, bonjour test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}