const regex = /(\b\w{4,}\b)(?:.*?\1){4,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\w{4,}\\b)(?:.*?\\1){4,}', 'gm')
const str = `hello, bonjour bonjour, ceci est un test dans lequel bonjour est écrit cinq fois et test seulement quatre fois, bonjour test, bonjour test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}