re = /(?:.*?)\{(.*?)\}(?:[\[((.*?))\]]*|[\{(.*?)\}]*)/m
str = '\\DeclarePairedDelimiterX{\\Set}[2]\\{\\}{\\,#1\\;\\delimsize\\colon\\; #2 \\,}
\\DeclarePairedDelimiter{\\card}{\\vert}{\\vert}
\\DeclarePairedDelimiter{\\abs}{\\vert}{\\vert}
\\DeclarePairedDelimiter{\\norm}{\\vert}{\\vert}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end