package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z]\w*`)
var str = `Hi, How are You?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}