import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]+\\s*\\|(\\s*<info>[^<]+<\\/info>\\s*\\|)+\\R+[+-]+\\R+\\|([^|]+\\|)+\\R+[+-]+";
final String string = "+--------+------+-------+\n"
+ "| <info>number</info> | <info>char</info> | <info>word</info> |\n"
+ "+--------+------+-------+\n"
+ "| 1 | a | alfa |\n"
+ "| 2 | b | beta |\n"
+ "| 3 | c | gamma |\n"
+ "+--------+------+-------+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}