const regex = /(?<=^|\n)(?<title>.*\*\*.*)(?<text>(?:\n.+)+?)(?=\n.*\*\*.*|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\n)(?<title>.*\\*\\*.*)(?<text>(?:\\n.+)+?)(?=\\n.*\\*\\*.*|$)', 'g')
const str = `📌 **Initial Planning Phase** (00:00 - 15:00)
Team discussed general goals and expectations
Roles and responsibilities briefly outlined
📅 **Timeline and Milestones** (15:01 - 30:00)
Reviewed draft timeline for deliverables
Proposed checkpoints and review dates
📝 **Budget and Resources** (30:01 - 45:00)
Preliminary budget reviewed by finance team
Need identified for additional cost estimates
🎨 **Design and Branding** (45:01 - 60:00)
Need identified for additional cost estimates
Need identified for additional cost estimates`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}