$re = '/^(.*? - .*?) - .*/m';
$str = 'a - b - c - d
z - c - b
y
u - z';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;