package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)source {15}(\d+)\.\.(\d+)\n`)
var str = `FEATURES Location
source 1..2558
/organism="name"
/mol_type="genomic DNA"
/submitter_seqid="scaffold077"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}