re = /^([^.]*)(?:(?<!\/|--)|\/--)$/m
str = '/avocado/banana/apple/--'
subst = '$1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result