package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a|b|c|d|e|f|g|h|i|j|k|l|m|n|o|p|q|r|s|t|u|v|w|x|y|v|z`)
var str = `a122334`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}