$re = '/<img (?:.*?class=[\'"](?!google[ \'"])(?![^\'"]* google[\'"]).+?[\'"]|(?!class=[\'"]))\s*[\/]?>/';
$str = '<img src="https://google.com/animage.jpg" class="google">
<img src="https://yahoo.com/animage.jpg">
<img src="https://google.com/animage.jpg" class="google">
<img src="https://yahoo.com/animage.jpg" class="azerty">
<img src="https://yahoo.com/animage.jpg" class="not-a-google">
<img src="https://yahoo.com/animage.jpg" class="azerty still-not-a-google">
<img src="https://yahoo.com/animage.jpg" class="google-i-am-not">
<img src="https://yahoo.com/animage.jpg" class="azerty still-not-a-google" rel="google">
<img src="https://yahoo.com/animage.jpg" class="azerty still-not-a-google" rel="google"/>
<img src="https://yahoo.com/animage.jpg" class="azerty still-not-a-google" rel="google" />
<img src="https://yahoo.com/animage.jpg" class="" rel="google" >
<img src="https://yahoo.com/animage.jpg" class="totally-a google" rel="google" />
<img src="https://yahoo.com/animage.jpg" class=\'i-love-myhtml-with-single-quotes google\' rel="google" />
<img src="https://yahoo.com/animage.jpg" class=\'i-love-myhtml-with-single-quotes not-a-google\' rel="google" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);