re = /\.+\s*(.+)$/m
str = 'VAL................................ Deal value ($ Mil)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end