package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^,])\s+`)
var str = ` 1 234 556 , 555 `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}