re = /^mysql:\/\/(.+?):(.+?)@(.+?)\/([^?]+)/
str = 'mysql://user:pw@host/db?reconnect=true'
# Print the match result
str.match(re) do |match|
puts match.to_s
end