$re = '/inclusion(.+?)exclusion(.+)/s';
$str = 'inclusion : ajjsdijd
sdsjdjs
ieroeito trorg inclusion
sdkjwedk
exclusion :
sdkjwdowek
ksdldk exclusion
skdkefk
kfkwkfwe ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);