import re
regex = re.compile(r"<meta name='(.*)' content='(.*)'>")
test_str = ("<meta charset='UTF-8'>\n"
"<meta name='keywords' content='your, tags'>\n"
"<meta name='description' content='150 words'>\n"
"<meta name='subject' content='your website's subject'>\n"
"<meta name='copyright' content='company name'>\n"
"<meta name='language' content='ES'>\n"
"<meta name='robots' content='index,follow'>\n"
"<meta name='revised' content='Sunday, July 18th, 2010, 5:15 pm'>\n"
"<meta name='abstract' content=''>\n"
"<meta name='topic' content=''>\n"
"<meta name='summary' content=''>\n"
"<meta name='Classification' content='Business'>\n"
"<meta name='author' content='name, email@hotmail.com'>\n"
"<meta name='designer' content=''>\n"
"<meta name='reply-to' content='email@hotmail.com'>\n"
"<meta name='owner' content=''>\n"
"<meta name='url' content='http://www.websiteaddrress.com'>\n"
"<meta name='identifier-URL' content='http://www.websiteaddress.com'>\n"
"<meta name='directory' content='submission'>\n"
"<meta name='pagename' content='jQuery Tools, Tutorials and Resources - O'Reilly Media'>\n"
"<meta name='category' content=''>\n"
"<meta name='coverage' content='Worldwide'>\n"
"<meta name='distribution' content='Global'>\n"
"<meta name='rating' content='General'>\n"
"<meta name='revisit-after' content='7 days'>\n"
"<meta name='subtitle' content='This is my subtitle'>\n"
"<meta name='target' content='all'>\n"
"<meta name='HandheldFriendly' content='True'>\n"
"<meta name='MobileOptimized' content='320'>\n"
"<meta name='date' content='Sep. 27, 2010'>\n"
"<meta name='search_date' content='2010-09-27'>\n"
"<meta name='DC.title' content='Unstoppable Robot Ninja'>\n"
"<meta name='ResourceLoaderDynamicStyles' content=''>\n"
"<meta name='medium' content='blog'>\n"
"<meta name='syndication-source' content='https://mashable.com/2008/12/24/free-brand-monitoring-tools/'>\n"
"<meta name='original-source' content='https://mashable.com/2008/12/24/free-brand-monitoring-tools/'>\n"
"<meta name='verify-v1' content='dV1r/ZJJdDEI++fKJ6iDEl6o+TMNtSu0kv18ONeqM0I='>\n"
"<meta name='y_key' content='1e39c508e0d87750'>\n"
"<meta name='pageKey' content='guest-home'>\n"
"<meta itemprop='name' content='jQTouch'>\n"
"<meta http-equiv='Expires' content='0'>\n"
"<meta http-equiv='Pragma' content='no-cache'>\n"
"<meta http-equiv='Cache-Control' content='no-cache'>\n"
"<meta http-equiv='imagetoolbar' content='no'>\n"
"<meta http-equiv='x-dns-prefetch-control' content='off'>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")