package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-zA-Z-0-9]+`)
var str = `acessorios-e-equipamentos-para-pintura_1_6_658_1_0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}